WordPress plugin template now PHP 5.2 compatible

In an ongoing effort to convert back my WordPress-related tools to WordPress minimum requirements I’ve modified my plugin grunt-init template to scaffold PHP 5.2 compatible plugins out of the box.
As usual the usage, once grunt-init is installed, is as simple as

mkdir /local-site/wp-content/plugins/my-plugin
cd /local-site/wp-content/plugins/my-plugin
grunt-init wp-plugin

since I love Composer to manage dependencies I’ve baked that into the template using xrstf Composer 52 extension to make Composer output a PHP 5.2 compatible autoloader.

I appreciate your input